» » »

Mercedes-Benz Q&A

Ask Your Question

1999 Mercedes-Benz ML430 Question: Hi, my ML430 has started stalling while I am at lights. It has happened 5 times

 

Question

james703, Beverly Hills, CA, November 13, 2012, 04:30
 Rookie

4 of the times it has re started straight away on first key turn but once it took several attemps.
Also I could be accelerating on a motor way and suddenly my accelorating power goes for 1 or 2 second and then returns.
There is nothing on the dash and it always starts first time, is full of fuel etc.
Just had a full service with filters and oil changes too.

4 Answers
Flag This
  • Answer #1

    Greg's Orange Auto (13627 Answers) , Orange, CA - (714) 361-9386
    globalhelper November 13, 2012, 05:40
     Master

    poss throttle body issues seek diag and est

    Reply
    Flag This
  • Answer #2

    your.mechanic November 13, 2012, 07:21
    Profile_thumbnail
     Master

    have technician diagnose

    Reply
    Flag This
  • Answer #3

    alan lutzi December 05, 2012, 11:27
     Enthusiast

    loose connection or failing sensor,get a diagnostic scan.

    Reply
    Flag This
  • Answer #4

    Spring Branch Imports from Spring Branch Imports, February 12, 2013, 21:36
     Technician

    This is not an easy fault to diagnose remotely.

    I would measure the 12v from the battery into the fuse box and see where it goes, if you have a fine probe you can measure the voltage on the various fuses and see if you can isolate the problem to a cable (if you are lucky) or the AAM if you are not.

    Reply
    Flag This