Help me... Transmission or something problem... on 2000 Ford Taurus

When I crank up the first time of the day it idles to about 3000 RPMs and then eventually goes down. Then when I put it in Drive and press the gas to go. It seems to work fine but doesn't want to shift out of 1st gear easily. It shifts after it hits 4000 RPMs... Only does it with the first gear first time cranking up for the day. Changed the Transmission filter and fluid. Fluid and filter was black and has medal shavings. Car is over 230,000 miles. I get great gas mileage. What could this be? I really need to know if I need to replace something. I'm in college and need a dependable car.. Thank you!

by in Monroe, GA on November 15, 2012
1 answer
ANSWER by on November 15, 2012
if you had metal and burn't fluid you may need a transmission. seek a free diag and est from aamco
Related Items:
I was driving and car started smoking real bad. I discovered that there was a leak of transmission fluid coming from a metal rod that sits in front of the radiator. It runs across the front of the ...
my car will not move. when I put it in gear it just won't go. Never have had this problem Checked the fluid it is overfilled, but no fluid as been added.try to drain the overfill. Tough right now t...
I find a small puddle of clear liquid, under the motor,and near my left front wheel, after parking, after driving a while. Opening the hood and looking down from over the liquid spot, the only area...
I started my car yesterday and a cloud of white smoke came out from under it. This has never ha...
My car is not leaking fluid....all the fluids are full. The thermostat does not go past half way to let me know its getting hot. The car starts to smoke on the right passenger side front corner aro...