2001 Ford Expedition Q&A

2001 Ford Expedition Question: Heating problem

No heat front or rear. Have hot hoses at the firewall. Replaced thermostat (twice), burped the system, replaced radiator, replaced water pump, flushed system. Blend door appears to be working by switching from cold to hot you get some variance. What would make both not work? -
Answer 1
Engine termperature or an air pocket still. You are correct to be looking at the engine, since temperature control would be odd to have a problem in front and rear both. With all those components and the existance of the auxiallary rear system, I would really spend extra time to work on getting air out. Hopefully that's all that's left. -
Related Items:
I have not been able to get the heat in my truck to get hot. The temperature control knob on the dash board lets me know when the engine is hot enough to turn the heat on, and I hear it blow when I...
driving uphill the interior right rear qtr panel and third fold down seat became very warm to touch (transferrred heat to golf clubs) is this normal or is there something generating the heat?
After a shop replaced the Mass Air Flow Gasket, both heaters failed. A/C works. Fine. Heat was working when I brought it in, as it was a cold day. No heat from front or rear. They can't figure it o...
I had the manifold and manifold gasket replaced along with the thermostat and since the front only blows cold air when heat is on but the back blows hot now I am smelling antifreeze also since the ...
So, here's what I've done: (1) checked coolant level, (2) confirmed blend door is working perfectly, (3) confirmed that both inlet/output tubes to the heater core on the firewall are hot, (4) torn ...