heater on 1999 Mercury Cougar

my blower works but it dont get warm. I changed the thermostat.

by in Buchtel, OH on February 25, 2010
2 answers
ANSWER by on February 25, 2010
Here are a couple of articles that will help you: http://repairpal.com/i-have-no-heat-what-could-be-wrong http://repairpal.com/weak-or-no-heat-is-it-the-heater-blower
2 people like thisFlag inappropiateReply
ANSWER by on May 25, 2010
I have the same problem. so far I've replaced the thermostat, heat coil and I'm in the process of replacing the waterpump today. My suggestion is to sell the car. Cougars are worthless, don't get stuck dumping money into it like I have. I owned mine for a month before it went to shit. since then it's been one repair after the next. It hasn't run right 8 out of the 9 months I've owned it. This'll be the last mercury I ever own. Btw the engine isn't getting water through it is your problem. Try what I tried but start with the water pump.
1 person likes thisFlag inappropiateReply
Related Items:
Anti-freeze leaking from drain at firewall, heater core is leaking, do i need to remove dash to replace?
The heat in my car has stopped working over the last couple of winters. Last winter it took about 30 mins to warm up but this winter it wouldn't ever get warm at all. The AC works okay... not sup...
i have a 97 merc cougar and we changed the thermostat and now the heater core is gone causing smoke to come through the vents am i able to bypass the heater core witho...
If you can,I'll need full details or step by step how to do this.You see I had a minor stroke and working or fixing things seems to have gotten not so easy to do and I can't seem to find a book on ...