» » »

Toyota Q&A

Ask Your Question

1999 Toyota Tacoma Question: heate

 

Question

joshypoo, Arbuckle, CA, November 07, 2010, 20:55
 Rookie

my truck no matter how long I warm it up or even drive it for the heater only blows luke warm air out all vents and I can't see any leeks. Plus I just got out the the US Marine Corp and have lived in San Diego, CA for the past 4 years so not sure when it stopped working.

1 Answer
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, November 07, 2010, 21:12
    Profile_thumbnail
     Master

    Where does the temperature gauge read if it doesn't get up to half way perhaps the cooling system thermostat is stuck open. Look at the back of the engine compartment look at the heater valve as you get a friend to move the heater control knob from cold to hot, make sure the heater control valve is operating fully from off to on. Look at www.rockauto.com you will see an image of the part..

    Flag This
  • Reply

    joshypoo, November 13, 2010, 18:32
     Rookie

    Thank you for your help, it wasn't the heater control valve but it was another valve that the nob controlled inside the truck that had been broken off and wasn't allowing the hot air to come in the cab.

    Flag This
  • Reply

    AKgrown, March 09, 2014, 19:22
     Rookie

    My Toyota has the same problem, but it doesn't seem to be the thermostat, the truck warms up fine, it just doesnt blow warm air. Can you tell me what valve or switch did work for you? I can't afford a new heater core, im hoping whatever you replaced will work for me too.

    Reply
    Flag This