» » »

Mazda Q&A

Ask Your Question

2003 Mazda Tribute Question: Heat blows colad and temp gauge is pegged on Hot

 

Question

ctime561, 3.0L V6, Jupiter, FL, December 15, 2010, 17:12
 Rookie

I noticed the temp gauge was all the way up on hot. I went to turn the heat on to cool the engine and cold aire blew out.

1 Answer
Flag This
  • Answer #1

    mastertech6371 December 15, 2010, 17:14
    Profile_thumbnail
     Master

    better have it checked for a blown head gasket. you may have overheated it and damaged the motor.
    then you need to find out why it overheated either from a leak or a bad thermostat.

    Roy

    Flag This
  • Reply

    ctime561, December 15, 2010, 17:19
     Rookie

    Thanks, I did not see any fluids leaking or white smoke from exhaust. Are there any home tests for a blown head gasket?

    Flag This
  • Reply

    Visitor, December 26, 2010, 08:44

    Hi Roy,

    I had it towed to the shop, and the water pump was seized, but I was told the engine checked out OK. So the pump, theremostat and hoses were replaced. After drving around for 30 min or so the fans came on, but ran OK. I thought mabe the sensor is shot from all the heat the night before. After I got on the highway and hit 70 she started to overheat, backdown below 70 ran cool, but the fans never went off. I went back to the shop and now the fluid goes from blue to yellow. I have been driving the car around town and highway for a week now. The fans come on and she gets hot at highway speeds, but no condensation out the exhaust, the oil is clean and coolant is not dropping. Any ideas. Thanks for your time. Stu

    Reply
    Flag This