2006 Kia Sorento Q&A

2006 Kia Sorento Question: had JUST had tune-up done--next day, #'s 1 & 4 ignition coils go bad

had JUST had tune-up done--next day, #'s 1 & 4 ignition coils go bad. Had that fixed now the car will run for 10min then shutdown and will not start. The engine will turnover but no start. But it will start after sitting awhile. Eyes new fuel pump that was not it. When spring fuel in throttle body it will start. so what will make the fuel pump run but not reach the fuel injectors? -
Answer 1
IS THERE A ENGINE LIGHT THAT WAS ON WHEN THE CAR RAN BAD AND YOU HAD TO REPLACE COILS 1&4 BECAUSE IT SOUNDS LIKE YOU MIGHT HAVE A BAD CRANK SENSOR -
Comment 1
Yes there were some codes. ..after the tuneup we cleared the codes and have not returned. I was think about the crank senser but wanted to ask first. Thanks -
Answer 2
I'm assuming when you say "spring" you mean spray? If it runs when you spray a combustable fuel (carb cleaner,starting fluid,brake clean) it is a lack of fuel not a crank sensor. You need to perform a fuel pressure and volume test with a fuel presure gage. Fuel pressure should be 46-50 PSI and at a ounce a second for volume. You need to have this done by a professional Tech. In all honesty it sounds like a bad fuel pump. You also need to verify if the injectors are firing. -
Comment 1
lol.. Sorry about the spelling I am trying to use my cell phone. To answer your question I checked the fuel pump and it seemed fine, but after reading some blogs on this subject I decided to look into it a bit more.. I pulled the fuel pump check for anything that may be wrong (trash), also check flow and pressure all good. . So I Started over and it would run for awhile then it would stop running.. I tryed spraying some starting fluid and it would start for just a second. so now I'm thing fuel pump again. I replaced the pump with a new one pump. Same result. Sometimes it will run for 1 min and then sometimes it will run for 30 min. Its like something is heating up or braking down and stopping the fuel flow. I know there is probably hundreds of things that control fuel flow but this all started with a tune up! my Car was running a bit rough so we had the plugs changed. Ran like a new car... then the codes (misfire #1 and 4 cylinder) and then it stoped all together. Machanic said we may have had the wrong plugs so we replaced them again. It ran like a new car again and then one day later it is dead again. this is crazy....Sorry about the crazy post ..... any ideas is greatly appreciated -
Related Items:
An engine misfire may develop due to a failed ignition coil. Our technicians tell us one coil is used for each cylinder. If one fails, often times another is not far behind. It may be worth cons...