1999 GMC Yukon Denali Questions

Answered 1999 GMC Yukon Denali Questions

Ask a Question
View:RecentAnsweredUnanswered
Recently my '99 Denali has been makeing a lound ticking/rattleing noise when in reverse. It appears to be mid-vehicle and only while in 2 wheel drive. The noise arrests when the Denali is in forward drive. I have not ...
Originally I changed the front differential. When I finshed I went for a test drive and my rear u joint broke immediately. I repaired the u joint and 1/2 mile later the u joint snapped again.
When I engage the 4wd the light flashes and it sounds like it engages but it isn't engaged or it kicks right back out. I fix my own vehicles but have never encountered this problem before and can't seem to find any in...
will move in 1st and then runs fine and sounds fine after shifts to 2nd. what are possible causes and likely fixes.
any online sites specializing in autmatic transmission and its eletrical components of a 1999 yucon denali that render the transmission to not having any gears i had a transmission blow its clutch making a terrible no...
i just put a new engine in a 1999 gmc yukon denalie it has a rebuilt transmission with less than 500 miles on it , i left the tranny in the truck dureing removeal and installation of the engine i have checked for br...
My 1999 yukon Denali pops and clunks when its cold and also shutters like its going to shut off, but it stops after I gun it and it warms up plus there is a smell like burning or somthing. I have greased slip yoke, r...
it also has a hard time going past 60 mph and issues with shifting
the line runs from the front to the back of the truck
Sometimes it will start and sometimes it doesn't start right away.
it wont move but it will crank up and when I put it in gear an give it gas the tire moves about 4inches and then I hear a clicking sound. Could the transfer case cause this to happen are what can this be ?????
My rear air is blowing, but not cold air. I had more freon put in today and it still did not blow cold. I was told that I needed to replace the orifice tube in the rear and that it was located in the passenger side ...
My yuan detail just died while I was going down the interstate.no warning signs and now it will not start .it just turns over.I ran the battery down ,so replaced battery but lost my codes.we have checked all the senso...
I replaced an O2 sensor about 3 weeks ago in my 1999 GMC Yukon Denali, it was bank 1 sensor 2. Then today I got an error code saying that I had a cylinder 5 misfire. Any suggestions or previous experience with this ...