» » »

Nissan Q&A

Ask Your Question

2000 Nissan Sentra Question: gage problems

 

Question

mclacomb, 2.0L 4 Cylinder, Springfield, VT, April 29, 2009, 16:55
 Rookie

First my gages keep going out and eventually will come back on. We thought it was a power issue due to our system (amp) draining too much power but that wasnt it. Now they arnt coming back on at all! What is this? And now im at a loss about my gages cause i can never tell how fast im driving and this car likes to go! If the RPM's at least worked i could estimate my speed by that and what gear i was in, but i loose the odometer, spedometer, RPM, and occassionally the temperature gage and fuel gage, but not always the last two. Please HELP!

2 Answers
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, April 29, 2009, 19:30
    Profile_thumbnail
     Master

    You have replaced the air flow meter with a Nissan factory unit which is good because I have seen a lot of defective reconditioned units. Check the wires that go to the unit. see if any of them are cracked or broken. Wiggle the electrical harness and twist it with the engine running see if the idle changes or the Check Engine Light comes on, if so the harness has a bad wire in it.

    Flag This
  • Reply

    patrick mannion, April 29, 2009, 19:36
    Profile_thumbnail
     Master

    There are two 10 amp fuses that supply power to the gauges number 30 and number 12 make sure they are good.
    If the lights to the instruments are the problem does your car have an after market stereo? It could be the wiring at the stereo that is causing the problem.

    Reply
    Flag This
  • Answer #2

    November 25, 2009, 07:41
     Rookie

    it is a problem with the unified controle unit wich is part of your gauge unit it should be replaced i was told but i took out 5 screws and 2 wire clips held it in and the plastic cover on the back wich just snaps on was poorly molded causing circet board to flex there is little stubes sticking up where the plastic filled the mold file or cut theis off they are aproximetly 1/8 inch round stubs some 1/4 inch tall i put mine back together without cover on back installed it worked just fine too

    Reply
    Flag This