107
questions

have replaced down stream sensor on bank 2 still have code also hesitates when accelerating at low rpm when cold stops soon after warm up

But then for no reason it cuts out and wont run but 10 mph blows out white smoke mostly, i pull over and restart then it runs fine for the next 10 miles or 100 i never know for sure

When trying to shift out of park, many times it won't let me. If I wait and/or press the brake a few times it will go in smoothly. Feels like the shifter is in lock position.
Problem is getting to happen more often.

The noise is a loud squeal and when letting off the accelerator it stops but starts up when accelerator is pressed again but when on level ground no squeal can someone help

Trucks been sitting up a couple months

toady I tried jump starting it, it wanted to start but I got nothing. its heating up the jumper cables. any ideas

black exhaust and jerks and lose power I throttle it to the floor it takes off will do it all day ford put a new turbo on and cleaned EGR valve when it was under warranty. did not fix it can you help

I hope it is working hope to get help

Exhaust and jerks and lose power I throttle to the floor it takes off will do it all day .ford put a new turbo on and cleaned EGR valve when it was under warranty. did not fix it can you help

This code keeps popping up.

I also seen black water leaking from my muffler

problem gets worse when accellerating

Truck stays plugged up on cold days it starts fine but has no power even when engine temp has got to running temp like trans is slipping but on warmer days it run perfectly fine no problems at all any ideas???

Had cool air this summer will not switch to heat. It is like the temp door is not moving.