1999 Ford F-250 Super Duty Questions

Unanswered 1999 Ford F-250 Super Duty Questions

Ask a Question
View:RecentAnsweredUnanswered
We took it to a desile mechanic and he could not duplicate it. replaced both batteries, they went through all the wiring, The horn does not work, changed the alternator. What else ??????
When I drive down the road I will hear a grind sound like 4 wheel wants to kick in , if I turn on the 4 wheel drive it will stop. I have to drive it in 4 wheel drive or it will do this all the time it is set on auto o...
Engine was able to be remote started, when put in drive and applied gas, it stalled out. Engine will turn over but won't start. Several hours later, it started. 24 hours later, it started but stalled out going down...
I drive an early build 99 Ford F-250 SD XLT Extended cab V 8 5.4 L Gas 6 speed 4WD. When I accelerate my truck in neutral gear it losses it's power and the engine stops working .When I have high beams ,cb radio, mark...
How hard is it to replace, all fuses are good fan does not work
99 f250 super duty runs rough at idel give it gas engine races then a couple second tach wil drop and start running rough again and when driving the tach will bounce up and down when slowing down I replaced engine tem...
i have cut the bed floor over the gas tank {i am replacing the bed}and dont see any thing with a 3 wire electrical connector except the sending unit fuel pump assy. no other wires going to the fuel tank. i have a new ...
replaced alternator but it still isn't charging, what else could it be?
THEN IT WILL TAKE FOREVER TO RESTART ONCE COOLED IT STARTS, I HAVE CHANGED FUEL FILTER; ASWELL AS THE FUEL PUMP......HELP
IM HOPING SOMEONE HAD THE SAME PROBLEM AND GOT IT FIXED, I APPRECIATE YOUR HELP!!!!!!!!!!
I will get to a point that it wont start again till it has cold down extremely or I opened the bleed valve on top were the fuel filter is..........help
Just replaced right bank injectors in my 7.3 turbo diesel. fuel pressure in filter is good, starter is good, ether will make it start but no throttle response. What things should I check?