Close

2003 Ford Expedition Questions

Get answers to questions about your 2003 Ford Expedition at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
141
questions

keeps blowing out when replacing it with a new one.

Just replaced thermostat and radiator overflow cap

Replaced switch still won't come out of park. No brake lights.

Car drove fine had been parked for 5 days. Started yesterday engine shoke the entire car - made loud noises. Shut up. Started again same thing - car was rocking and acted like it would run. Turned off again and a stream of oil gushed out from under the engine. Any thoughts?

themostat and timer belt

Hesitates during acceralation, stalled while driving, checked coils those are fine, service engine soon light came but no codes thrown

the best possible price,,i am very broke

pump works jumped it replaced relay on pump still doesn't work. i don't have the other relay with fins all fuses are good, ford says they don't make my control modual any more. 1fmfu18l93lb71962

no power when on highway and trying to pass cars

i purchases vehicle a week ago and the drivers side control panal for the electric windows, door locks do not work..waiting on a part from dealership to repair but need to load christmas present which is large into the bak need both rows of seats to lay down

I have a 2003 Ford Expedition...the battery light comes on and it says to check charging system. My gauge went all the way to L for my battery charge so I went and purchased a new battery because when they hooked it up to the machine it was only charged at 72%. It ran with no problem for 1 week. The auto zone guy even checked the alternator and he said it was nothing wrong. Then it started doing the same thing this past weekend. Took it back to auto zone and was told it was the alternator. Was on my way to my personal mechanic and the battery light went off, the check charging notification went off and the battery showed fully charged. My mechanic still put it on the machine but i was told since it showed no notification it showed nothing wrong. Last night I was headed to my moms and the gauge started going towards the L (low charge) again. I made it to my moms and turned my truck off, tried to start it again and it just clicked. Sat with my mom for 10min waiting on my fiance and when i went back out to try and start it, it started right back up and full charge. It cant be the alternator because it keeps starting back up with no need for a boost. Could it be the belt or is it something deeper...HELP!!!

When ac is on no cold air in the front area only on the back i check the freon level is full anybody know what's the problem

Back end looks jacked up... Rides high

diagnostic reads PO128, What do I need to do or replace. Thank you KP5205

i heard it was discontinued bye ford and i have called lots off junk yards to see if i can find one and every body says no ??????