1999 Ford Expedition Questions

Unanswered 1999 Ford Expedition Questions

Ask a Question
View:RecentAnsweredUnanswered
Has been twice already each time using different brands, the guide seems to just break off and fall into oil pan, bolts are still on engine
Makes sound on first start up only after that sound go's away,Changed out both idler pulley, belt tensioner, and belt but sound is still there I did get a P0171 fixed that but sound stayed
I have put on new tires smaller size back to stock size new lower ball joints on both sides and the loud popping noise got worse and more often with the smaller tires?
I just bought it like a week ago... Now the check engine light just came on....
I was advised that it is my intake manifold and should be replaced as soon as possible. I do believe it is an EXTREMELY SEVERE Leak as I am putting in oil as fast as it comes out. It is hard in today's world to know ...
I changed the coil check the plugs and wires all good
Two hoses under the hood one is hot to the touch and the other one isn't!!!
Truck shifts through all the gears, it maintains speed when u step on gas for passing gear.let off gas when speed drops to 50 mph it works
I smelt it inside the cab of vehicle and now I am afraid to drive it do to having 6 kids in it with me and how hot it is in SC
The air suspension has gone out on my truck for the second time. I know my truck is very old but it's gotta last me just a little while longer. I replace the first air susp. system with one from an after market system...
Overheating when on interstate, new thermo, new coolant do you know where the temp sensor is and if it has 1 or 2