every thing works, lights, radio, everything but won't crank over, no sound, nothing. on 1997 Acura CL

when i parked it it was fine but now won't turn over. turn the key to start it and it does nothing but a small cicking under the dash. can it be the starter or some fuse?

by in Gainesville, FL on April 19, 2010
2 answers 2 comments
ANSWER by on April 19, 2010
Start with the battery and battery cables as a weak battery with one of the six cells bad will still turn on the lights ect but won't have enough amps to start the engine. Take the battery to a auto parts store (Napa) and have them load test it and make sure the cables are clean and tight
COMMENT by on December 08, 2010
I am having the same problem with a 2007 Chevy Malibu Maxx (should've stuck with Ford, lol). It's been very cold here lately, I'm talking 20's and my car won't start in the morning. All the lights and radio come on and then nothing...no rrrrrrrrr or click click click...NOTHING. So I went and got my neighbors truck to jump it...NOTHING. Let it sit connected to the truck...still NOTHING. Came home that afternoon and she fired right up no problem!? Drove it that night, no problem! Next morning...same thing. I went and had my battery tested....100%, no problems, plenty of amps and everything. Checked my connector thingys on the battery no corrosion, no moisture, nice and tight, nothing. I haven't had ANY problems with this car and can't afford a problem right now with Christmas right around the corner. Any suggestions other than buy a torch? I'm desperate!!
ANSWER by on July 23, 2010
battery dead go to autozone get a new one
COMMENT by on October 23, 2010
Thanks so much for this posting I took your advice for the same issue with my 04 impala and it works great now it had 1 dead cell

Related Content