» » »

GMC Q&A

Ask Your Question

1990 GMC Safari Question: engine wont idle running rough tune up brand new tps new possible cause ?

 

Question

nitrodave, 4.3L V6, Garden City, MI, January 06, 2011, 14:58
 Rookie

Problem occurred on Sunday 1/2/2011 the van was trying to stall at a light. Managed to get it home without stopping and when I pulled into the driveway it stalled out. Its been running rather rough and will not idle correctly ever since! Installed new tune up parts, plugs, wire, rotor,cap and then I pulled an error code 22 from the dash lights and replaced the TPS switch check engine light went away and no further fault code and van still running the same!

1 Answer
Flag This
  • Answer #1

    Stan's Garage (113 Answers) , Dearborn Heights, MI - (313) 915-4196
    Stans Garage January 18, 2011, 12:20
    Profile_thumbnail
     Journeyman

    It sounds like you have some type of electronic problem. You will have to have it check on an electronic scanner ASAP so not to do more damage. Contact my shop and we can schedule you an appointmnet.

    Flag This
  • Reply

    jas57, October 11, 2011, 14:10
     Rookie

    I have the exact same van and need to know what was found to be the problem with the van..

    Flag This
  • Reply

    JimN, January 21, 2012, 20:25
     Rookie

    I live in Virginia and have the same issue with my 2003 Safari. Runs really rough and wants to stall. I did full tune up and replaced O2 sensor. It seemed to work for a day or two then went bad again. It acts like there is an electical problem as well. Gauges go weird once in a while. Any known issue that the group can share would be helpful. I don't know where to look next.

    Reply
    Flag This