» » »

Suzuki Q&A

Ask Your Question

2001 Suzuki Vitara Question: engine stops running

 

Question

lipamimac, 1.6L 4 Cylinder, Lufkin, TX, July 12, 2010, 20:54
 Rookie

car stops running after driving for 20 minutes and have to wait 20 minutes to cool down and start it back on . I have replaced the spark plugs , thermostat , fuel filter .

2 Answers
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, July 12, 2010, 22:06
    Profile_thumbnail
     Master

    When the car restarts does the Check Engine Light/service engine soon light come on? If so trouble codes are stored in the computer that are retrieved using a scan tool. These codes will indicate where the problem is. The problem is likely to be something that is sensitive to heat like a sensor, computer, relay or fuel pump. It is important ot narrow down your diagnostics by seeing when the car fails, do you have spark, fuel or triggering of the fuel injectors.

    Reply
    Flag This
  • Answer #2

    September 18, 2010, 13:01
     Rookie

    I had the same problem and it turned out to be the cam position sensor located on the back of the engine at the base of the valve cover. I would have never found it if somebody else I know didn't tell me about it. Mine did not alarm the computer. If you want to confirm before purchasing part, pull out the sensor when the cars cuts out and just cool it in the air for a couple minutes then put it back in, if the cars restarts that's your problem. Unplug the cable and ground remove one 10mm bolt on top, and pull straight up. It's an o-ring seal be ready for a little very hot oil to come out.

    Reply
    Flag This