engine shuts off when it feels like it on 1995 Dodge Ram Van 2500

It runs perfect for 5 minutes, or a day, a week or a month..no spit or sputter engine just stops, wait anywhere from restart instantly or sometimes wait up to an hour and it will start and run excellent. The cycle starts all over again. Already changed the CKp - it doesn't matter if I'm doing 2mph or 50mph or stopped when it feels like stopping it stops. The error code is 37, dont think that is the problem outside of the 12 for the battery disconnect and 55 end of codes

by in Monroe, NC on December 02, 2009
5 answers 1 comment
ANSWER by on December 02, 2009
Does it die driving done the road, at idle, a little more info would help please. Confirmed Fix: CKP (Crankshaft Position) Sensor Problem Description: Vehicle ran rough and stalled when put into reverse on cold engine-No trouble codes.Performed fuel pressure,volume and leakdown tests.Inspected sensor data-found loss of crankshaft sensor. Replaced crankshaft sensor with new.Problem solved. Vehicle Description: 1995 Dodge B2500 5.2L, GAS, Vin Y, Eng Cfg V8 Category: Engine Performance Stalling
COMMENT by on June 15, 2010
also I failed to mention that on this Dodge 2500 van when it shuts off the ignition is shut out and theres no power to distributor nor cam sensor are crank sensor... possible failing PCM?new engine ignition components.
ANSWER by on June 15, 2010
currently working on a 1998 dodge 2500 van with a 5.2 ltr engine, if I let the hood drop and close the the engine revs up then dies. Secondly ICAN UNPLUG THE CAM SENSOR and the engine continues to run. thirdly while driving the vehicle it dies and after an short moment will restart n travel another 10 to 30 miles and shut off again.
ANSWER by on November 14, 2010
That sounds Like a bad ignition module. When it gets hot it shuts down and depending on outside temp it could restart right away or need to cool for awhile then restart. When the module shuts down its like turning the key to off. Next time it happens check for spark right away
ANSWER by on December 05, 2010
37 is trans no code check your coil and wire 92 to 96 has a problem with the connector so tighten the connecter to the coil
ANSWER by on December 31, 2010
I dont think I ever cheked error code but when i had fuel injectors cleaned (truck had 200K miles) PROBLEM went away!

Related Content