ENGINE SHUTS OFF ON ITS OWN!!!!!!!!!!!!!! on 2007 Chrysler Aspen

SOMETIMES WHEN I START MY CAR IN THE MORNIGN TO WARM IT UP , IT WILL BE RUNIING FINE FOR ABOUT 5-8 MINUTES AND THEN THE ENGINE SHUTS OFF. THE RADIO IS STILL ON AND IF THE HEAT WAS ON , IT IS STILL RUNNING, BUT THE ENGINE SHUTS OFF. THE OTHER DAY WHEN I WAS DRIVING DOING ERRANDS ETC. I CAME TO A RED LIGHT AND WAS SITTING THERE WAITING FOR LIGTH TO CHANGE AND MY CAR TO SHUT OFF??????? wHEN i FIRST BOUGHT MY CAR THIS HAPPENED BEFORE AND I BELIEVE THEY SAID IT WAS MY CAMSHAFT SENSOR, I AM TAKING MY CAR IN TO BE WORKED ON IN A COUPLE OF DAYS. WHY AM I HAVING THESE PROBLEMS AGAIN???????

by in Williamstown, NJ on February 19, 2009
2 answers 1 comment
ANSWER by on February 20, 2009
2007 4.7L camshaft position sensors failures are not that common. More common that not is a Dirty throttle body. Contaminates from combustion gases leave a residue on the throttle plate and bore called "coking". This condition will restrict air flow through the throttle body when the throttle is closed, as being at a stop light. Common symptoms are stalling on decel (foot off gas), hard starting, stalling at stops. This seems to fit your concern
COMMENT by on July 26, 2011
so what do you do? My 07 4.7L has started stutter start when I turn it on. It turns on, but he light flicker and it makes this weird noise like it is trying to crank a couple of times and then it kicks on? Could this be the same thing?
ANSWER by on August 13, 2010
is it the cam sensor