Car Problem Reports

Cadillac Catera Engine Performance Problems Due to Crankshaft Position Sensor Failure

 
Cadillac Catera Problem
21 Reports
Me Too
Edit

Model Years Affected: 1997, 1998, 1999, 2000, 2001

Engine Affected: 3.0L V6

Average Mileage: 111,920 mi (40,000 mi - 200,000 mi)

Verified

The crankshaft position sensor may fail causing the engine to stall while driving and/or will crank but not start, especially when the engine is warm. The car may start again if it is left to cool off, but it may run roughly or have poor performance.

  • Nottinghill, , 3.0L V6, 115,000 mi
     Rookie

    Replaced crankshaft sensor. Car still will not start until cooled down.The oxigen sensor was replaced also. Can this be a thermostat-radiator problem

    Flag This
  • Visitor, , 3.0L V6

    The car runs and then when try to start it like 5 minutes later it doesn't. I need to let the car off for about 1/2 hour.

    Flag This
  •  Rookie

    My car won't start when hot even after 40 minutes?? Has to sit for over an hour for it to start. I've had the starter replaced a year&half ago, valve cover gasket changed, battery fully charged just don't get it. I'm a female & don't need to be dead in the water in the middle of the night.. Any suggestions?????

    Flag This
  • Visitor, , 3.0L V6, 200,000 mi

    Engine quits while running and needs to be restarted

    Flag This
  • Visitor, , 3.0L V6, 123,000 mi

    Engine quits while running and needs to be restarted

    Flag This
  • daniyel22, , 3.0L V6, 178,620 mi
     Rookie

    My car won't start when hot outside even after an hour?? Has to sit for over an hour or try early in the morning for it to start. I've had the battery and replaced crank sensor because Speedometer stop working and therefore mileage counter stopped. I just don't get it... Any suggestions???????

    Flag This
  • Visitor, , 3.0L V6, 52,500 mi

    I bought this 1999 Cadillac Catera and lately it has shut down in traffic. During the winter it ran great. Now that it getting warmer it runs for a while, then stops by itself and cranks back up after 15-20 minutes. This may be my problem b/c it's grown to be tempermental and a little scary, especially in rush hour traffic

    Flag This
  • Stalls after 10 mins of driving then starts again ater 20 mins of been cooling ..

    Flag This
  • Visitor, , 3.0L V6, 54,000 mi

    Had earlier problem of valve cover gasket leaks, about 1500 miles after that was fixed the car would not start after parking, cool down and restart. Twice it just stopped running and would not restart. Took to shop and dagnosis was crankshaft position sensor failure due to being saturated with oil, likely from previous valve cover gasket leak problem. Replaced sensor and now running OK but valve cover leak problem is returning so will need to pay attention.

    Flag This
  • jokajm235, , 3.0L V6, 65,000 mi
     Rookie

    driving on rt 95 at 60 mph and car shut off and lost power.. car would only drive til engine was warm then shut off.. i still had a warrenty from the dealer i bought it from and was replaced at no cost to me..

    Flag This