"Crank no Start" Due to Failed Crankshaft Position Sensor on Mercedes-Benz ML320

The crankshaft position sensor may fail. Symptoms of this are: The engine will crank—but not start—especially when the engine is warm. The car may start again if it is left to cool off, but it may run roughly or have poor performance.

RepairPal Verified
Average mileage: 141,263 (50,000–272,000)
6 model years affected: 1998, 1999, 2000, 2001, more2002, 2003
51 people reported this problem
The nation’s largest network of independent repair shops certified for expert training, quality work and fair pricing
Viewing
1
-
20
of
31
problem details
2000 Mercedes-Benz ML320 127,000 mi,
My car shuts off after running for approximately 10-15 mins. It shuts off when i come to a stop. I had the battery and alternator checked. I was told i need a fuel pump,then i was told i needed a starter. None of these answers felt right. So i decided to research the problem and im glad i did. By reading the other post it will save me some time and money thanks.I will post later after i have the crank shaft sensor replaced.
I don't seem to have these common problems but I am being told it is the crank sensor. My problem is the car starts ok and drives ok for about 30 miles or 30 minutes. Then if I try to accelerate above 50 mph - the car doesn't react - i put my foot flat down and it just stays at 50 mph - it doesn't stall or anything like that but then when i get to lights and stop the motor is very rough - like it is running on 4/5 cylinders. Does have anyone had a similar experience ? I have many different answers from people. 1. they say rocker gasket broken and oil getting into spark plugs - dos make sense to me. 2. others they say changer spark plugs 3. change leads 4. change fuel filter. Any help really appreciated. Also suspension seems very rough - now I have ben told i have sports suspension - it there any way to smooth it out can i change anything on suspension. Also what tyre air pressure should i put in the tyres some say 44 psi but that seems hight to me thanks for a lll help regards Ross
car cranks and drives after a while it shuts off and will not start until after a few minutes and it cools off
the car stalls and won't start several times and it would not start sometime 30 or 40 minutes later, but still it won't go far before it stalls again.
2001 Mercedes-Benz ML320 127,000 mi,
replaced CPS car started ran for about 25 miles shuts off AGAIN. Don't know what to look at next? Anyone ?
2000 Mercedes-Benz ML320 200,691 mi,
I turn it on but it start for a sec next thing it shut down what the problem
1999 Mercedes-Benz ML320 135,000 mi,
Car died at a stop light - every light on the dashboard came on - I tried to restart - almost sounded like it was running - waited about 15 minutes dorve it to a garage - unfortunately not Mercedes a new crankshaft POS was put in - still cut off.
2002 Mercedes-Benz ML320 167,000 mi,
It has not been fixed yet. When I turn the key, i can hear the engine "click" and make a stalling noise. It usually ocurs after I've turned the car off and try to restart after about 15 minutes. I typically allow it to "cool off" and then it starts up fine. Occassionally, I will hear a stalling sound when I try to start it in the morning. It will start, but it sounds like it's stalling.
2001 Mercedes-Benz ML320 98,000 mi,
Having the same issue, i've changed the battery, mass airflow sensor, and trottle position sensor, and still cranks and dont start, only after like 15-20mins. Then also another problem just came along, when it finally starts, it stays in 1st gear.
My ML320 would run hot and shut off while I was driving or at a stoplight. My mechanic put on new fuel pump even though I had gotten a fuel on April 27, 2009. Now he thinks its the crankshaft position sensor.
1998 Mercedes-Benz ML320 248,680 mi,
Will not start at all
Got towed to dealer by AAA. Cost to fix $450 parts and labor
2002 Mercedes-Benz ML320 215,000 mi,
It will run for 30 mins or so then one i come to a complete stop it will start making this weird sound like it's not in the right gear or something n it will start shaking then it will start sitting of n when ipress the gas it accelerates a lil then stops again n then seems like it wants to go again but it will shut off on me n then i have to restart n it will do it again after like 2 mins
2002 Mercedes-Benz ML320 83,500 mi,
Engine stop suddenly, while it works fine. Will start only after a period of time (minimum 20 minutes) and happens more often now, progressively. I do not repair it yet, as unable to diagnose correctly yet. Reparation will occur in a few months.
1999 Mercedes-Benz ML320 116,509 mi,
Same problem. Shutts off and restarts after several minutes. But it does run ok after it starts. It is happening moee often and tlaking longer to restart.
2002 Mercedes-Benz ML320 153,000 mi,
same thing crank no start when warm if you let cool it will start. replaced the crank position sensor.
2000 Mercedes-Benz ML320 230,000 mi,
Had bad water pump, replaced that...and now it iseems this problem.
2000 Mercedes-Benz ML320 153,000 mi,
stall and no restart no spark let cool 20 min and would restart replaced crank sensor so far so good
engine shuts off after warming up. will restart after engine cools off but runs & idles rough
replaced part at dealer, total cost P&L $425