Engine ON and OFF on 2007 Chrysler Town & Country

Went to go to church this morning, September 11, 2011, started the car, (cold engine), and after about 3 to 5 seconds the engine quits working. On attempt to restart the engine just turns over with no attempt to start. After an hour or so it can be restarted, but it continues as above. 3 to 5 second run, stops, etc.

by in Lacey, WA on September 11, 2011
1 answer 2 comments
ANSWER by on September 11, 2011
You need to isolate if you have no spark or fuel. I suspect you have a bad fuel pump. You need to isolate what you do not have.
COMMENT by on September 11, 2011
I do have spark and fuel.....for all of 3 to 5 seconds. Unless the fuel pump has gone bad in the last four months, (when it was replaced by a dealer), since the last one lasted 4 years, I dont see that as a cause.
COMMENT by on September 11, 2011
Well if you have spark and fuel that leaves compression. A four cycle gas engine requires ignition(spark),fuel and compression. Just because you had the fuel pump replaced at the dealer doesn't mean that you couldn't have a fuel delivery problem. You say you have fuel, what is the pressure on a fuel pressure gage.
Related Items:
We replaced the engine in my E350 Ford van. It idles great, but as soon as we step on the gas,...
This happened once before, but magically "fixed itself" and I never had it looked at. Car's be...
STARTS FINE WHEN ENGINE IS COLD. AFTER IT REACHES OPERATING TEMP IT WON'T START AGAIN UNTIL THE ENGINE COOLS OFF FOR ABOUT 30 MINUTES THEN IT STARTS FINE. NO CODES. REPLACED CAM POSITION SENSOR,...