engine on on 2004 Mazda Tribute

Hi, My car ran fine until it rain very hard here. I started it the next day and the check engine light is on and it ran a little ruff. jane-ww@hotmail.com

by in Saint Cloud, MN on June 23, 2011
1 answer
ANSWER by on June 23, 2011
Sounds like a classic example of ignition spark leakage due to insufficient insulation of the coil boots, where the mount to the spark plug. The boots should be replaced, as well as the plugs while you're there. If problems continue, an actual coil could be faulty, but start with the basics... ...or better yet, have a diagnostic test performed to really hone in on the issue.
Related Items:
If the engine is misfiring, it may be caused by a damaged wire(s) which connect the fuel injectors to the Powertrain Control Module (PCM). The damaged wire(s) can be repaired or the emission wire ...
Today I went over a friends house to check out her car. When I tried to start the car it only continued to crank but no start. Sounds like a normal crank. I checked and verified there is good spark...
I just had the ignition housing assembly changed out and 2 recalls done at the dealer.Recalls on the electric power steering assist which they reprogrammed the power control module and ignition con...
engine light came on while driving thru parking lot. engine started missing, temp gauge went to hot(engine was not hot)waited a while, car ran fine for 15 minutes. now, engine tries to crank but wi...
Car has 225,000 miles. Engine idles and runs rough. Codes P0304 and P0306 are active. Replaced all 6 spark plugs. IAC valve and MAF sensor were replaced 6 months ago. Swapped coil packs from cylin...