» » »

Jeep Q&A

Ask Your Question

2006 Jeep Grand Cherokee Question: Engine light on and wont go off and blows white smoke

 

Question

Chuck Dodge, 4.7L V8, Maryville, MO, November 08, 2012, 19:14
Profile_thumbnail
 Enthusiast

My jeep blows white smoke out of the tail pipe when i start it but stops after a few minutes. The engine check light is on and keeps coming after being cleared 3 times by a shop. 2 times by a shop once by a dealer. The code says that it has a misfire on the 8th cylinder but it has only misfired one time, all though it was shaking like crazy when it did it. It also lost all of its coolant once but hasnt lost any since. I had the spark plugs replaced to fix the misfire and seemed to but the computer doesnt seem to think so. Unfortunatly i havnt been driving it as much as i used to because to protect it from people at work, (no respect for nice looking vehicles), i dont know if that has any effect or not but im clueless and dont want to blow thousands of dollars at a dealer to find out that its not what i paid for. Thanks for help

4 Answers
Flag This
  • Answer #1

    pushrod November 08, 2012, 19:45
    Profile_thumbnail
     Master

    HAVE A COMBUSTION LEAK TEST PERFORMED AT MOST ANY REPAIR SHOP. BEST GUESS IS HEAD GASKET LEAKING COOLANT INTO COMBUSTION CHAMBER. THIS TEST IS FOR COMBUSTION (Co) IN COOLANT SYSTEM AND IS VERY RELIABLE.

    Flag This
  • Reply

    lawrence c johnson, December 17, 2012, 21:27
     Rookie

    sounds like head gasket, probably reseals when warm. I have used a sealant with great sucess try Bars Leak

    Reply
    Flag This
  • Answer #2

    your.mechanic November 08, 2012, 21:05
    Profile_thumbnail
     Master

    blown head gasket

    Flag This
  • Reply

    Chuck Dodge, December 16, 2012, 19:25
    Profile_thumbnail
     Enthusiast

    Thats what i was afraid of, any one know how much a head gasket job will cost

    Reply
    Flag This
  • Answer #3

    Greg's Orange Auto (13378 Answers) , Orange, CA - (714) 361-9386
    globalhelper November 09, 2012, 06:35
     Master

    get a diag from your mech could be haed gaskets

    Reply
    Flag This
  • Answer #4

    lawrence c johnson November 15, 2012, 06:19
     Rookie

    sounds like head gasket try a manufacturers sealant

    Flag This
  • Reply

    your.mechanic, December 16, 2012, 20:20
    Profile_thumbnail
     Master

    Yes, the head gasket tried the manufacturers sealant...and failed!

    Reply
    Flag This