electrical problem on 2001 Chrysler Town & Country

when the key is in the ignition and in the run position everything works, the radio, the ac, the wipers, door locks and power windows, when you start the engine it stops working, why?

by in Potwin, KS on July 17, 2013
Get Your Car Fixed at a RepairPal Certified Shop.
We certify shops based on expertise, quality work, and verified customer reviews
2 answers 5 comments
ANSWER by , July 17, 2013
Wiggle key while engine is running, if stuff starts working or attemps to work, have ignition switch checked. Scan test will help also!
COMMENT by , July 17, 2013
I tried that and get no response, do you think it is the switch or the ignition itself? I brought it to a local mechanic and he said it could be a body module, is that a possibility?
COMMENT by , July 17, 2013
Yes, that is what the scan test is for. However it sure sounds like the electrical part of the ignition switch but all we can do is guess at it!
COMMENT by , July 17, 2013
Thank, I went and got the switch, started changing it out only to find the final screw that holds the switch in place is one that has the pin in the middle of it, guess chrysler wants to make it as hard as possible.
ANSWER by , July 17, 2013
AGREE WITH PUSHROD POSS WORN OUT IGN SWITCH.
COMMENT by , July 17, 2013
I installed a new switch and same problem, tomorrow I bring it to the mechanic, he says it is a body module, will post what happens when I get it back so all can know what the problem is for future reference. thanks for the help
COMMENT by , July 17, 2013
Good idea!