egr valve terror on 1993 Chevrolet S10 Blazer

I can't seem to figure this out my car started bogging up hills wouldnt go more then 20 mph so i check it all out and it said egr valve was out i replace it it solve the problem for 1 week then went back to the same problem so i replace the egr again but it didnt fix it again im stuck and cant figure this out i clean it out and stuff just to clean it out now it works partily and go up hills if i step light on the pedal but if i press hard on the pedal it gets stuck or just starts clicking and slowlys losses speed enay help its cursed

by in Oakhurst, CA on April 28, 2009
2 answers 2 comments
ANSWER by on April 28, 2009
You may have a plugged exhaust, poor fuel delivery, engine airflow meter.can be many things. What codes are you getting?
COMMENT by on April 28, 2009
thats the thing i not getting enay codes emaymore just doesnt want to go up hills at a reasonble speed though one day i had the e brake on and was driving but the ebrake doesnt work to well and i ran lucas fuel cleaner trough it and afther that it seem to start meesing up again
COMMENT by on April 28, 2009
Have the exhaust checked, you may have a plugged catalytic converter. Have the fuel pressure checked, especially under a load. Good Luck!
ANSWER by on May 10, 2010
I had the same thing happen on my 1994 blazer. Turns out there are a lot of deposits in the duct upstream of the egr valve that break off with vibration. So when I get the valve cleared after it sticks, some more crud breaks off and the valve sticks again. The solution I did was to disconnect the valve in the open mode. Car rruns smoothly now.