fuel pump wont turn on,checked all relays and fuses, no spark,it cranks but wont start

Have changed the bulbs and checked the fuses.

engine restarts most times after cycling the key. some times i have to wait 30 sec or more but it always restarts. some times it will buck driving down the road at highway speeds but then picks back up on its own. van has 218,000 miles. engine also has had a coughing and stumble for a while but this is a new issue.

Getting 10-12mpg now, uphill, straightway, stop and go. Need more mpg!!

When it does turn over, the starter sounds healthy. Where is the solonoid? Is it on the starter or seperate? And I can't seem to find the starter. Sometimes takes as long as 100 tries before it starts. I need to know what I"m up against. Thanks for your time.

loud wheezing, grinding noise. ring -pinion need lubed

Wanted some info before I took it to be reapired or if this can be done by me. Does this happen a lot?

It looks clean, and i keep it full, but i have heard different thoughts on whether or not i should change it at this mileage. What do you think Should I or shouldn,t I?

it starts hesiating acting like it wants to cut off sometimes it even back fires it has a new fuel pump plugs,wirers,and distriber i dont know what else todo

the problem started a few weeks ago,and has just progressed to more frequently. sometimes it will crank and run all day,and other days it will act like it aint getting gas to start up. it will jerk and gargle spit sputter and finally after i prime it enough it will run enough to stall going down the road.

I have a friend who has a dodge van, he said that when he goes down the road once the van warms up and sometimes up to 50 or 60 miles the engine will just shut down and not crank back until it has cooled back down, but it is still firing according to his mechinic.He has spent about 800.oo on the van so far and is stil haveing the same problem. I know he has replaced the computer, the sencers, thromostat, and just about every thing electrical that could cause the problem. I had a volkswagon that used to do the same thing and it was a relay that regulated the fuel, it worked like a set of points, does the van have one of these on it somewhere??

my van only starts if I hold the gas pedal

brake lights do not work

seems silly but i cannot seem to locate air filter any clues?

the d code said it was o2 sensor, replaced the primary bank1 sensor1 still starts chugging along engine pops a bit when i pump gas pedal it will sometimes just start going again until i begin to slow down, when up to speed 50mph plus runs fine.Mechanics keep saying it could be a number of things how do i narrow it down to the actual problem