112
questions

Surging problem goes and comes. Disconnecting and reconnecting 1 battery cable from 1 of 2 batteries cures the problem for a short time. Problem has been on and off for 2 years.

I can put it in gear and it would drive about a quarter mile then acts like it's in neutral. Let it sit for a few minutes and it would go back in gear and do the exact same thing again. Tried changing the filter and fluid, very clean no metal shavings fluid clear and not burned now won't move at all. Could it be my shift solenoids? It only has about 30k miles on a rebuild and has been perfect. A transmission hose came off spilling a few quarts, put it back on and refilled and ran fine then a few days later this happened. Any suggestions?

It makes the noise like the abs warning is on but the warning light does not come on yet the warning still works. It only happens once in a while and the truck does not stop.


transmission also vibrates when applying some throttle when already in overdrive. It is not the sensor, I have already had that replaced and the transmission shop says they cannot find anything wrong. I think it acts like the clutch in the overdrive is chattering (but I am not a transmission technician).

When i get going down the road it takes several mins to get cold.I drained al the freon out and refilled it but just blows colder when driving no difference when ideling.

everything seems to be working but it was out of refrigerant so I filled it 2 different times and this happened both times

Master cylinder replaced a year ago
Left front disc replace, front pads replaced
Rear pads good
Play in pedal at top of action.
No air in the system after repeatedly bleeding system to try and remove play.

Master cylinder replaced a year ago
Left front disc replace, front pads replaced
Rear pads good
Play in pedal at top of action.
No air in the system after repeatedly bleeding system to try and remove play.

I have changed the TPS with a new one and cables/connections look and test fine. I cleared the code, the problem still occurs but only when turning on the a/c. The a/c compressor works fine. The a/c system has a low charge but no trouble code shows for same. No other trouble codes are stored or show when the vehicle is run without a/c.

can anyone help

It happens if I floor it to go it falls on its face,then I let off it it starts going again

engine starts and idels just fineuntil you give it more throttlr

I did a partial tune up changing all but the wires, even changed distributor cap. My air intake housing has gaps, most of them I covered with duck tape. It sarts fine, and for the most part runs fine, but it acts like it wants to stall out and doesnt want to accelerate. Why?

After my truck gets up to normal running temp my motor will quit. I've had it happen with the truck parked and while driving down the road. It will not start again till the truck cools down. I've replaced the ignition coil.