2000 Dodge Grand Caravan Questions

Answered 2000 Dodge Grand Caravan Questions

Ask a Question
View:RecentAnsweredUnanswered
Scan tool says with engine warmed FF Fuel System Closed Loop Calculated load 16.8% Coolant Temp 206F STFT Bank 1 0.0% LTFT Bank 15.4% Intake Manifold Press 15,0 in.hg Eng RPM 1504 Veh speed 36 MPH If the ban...
only works on high, and driver side blows cold, and passenger blows hot.
One of the wires on the back of the alternator terminal is broken at the terminal. how can I fix it without spending a ton of money on a new wiring harness and garage fees? please help with any tricks I can perform at...
My friend replaced the blown head gasket. In the month since this, my car has had 2 broken serpentine belts, Each roughly two weeks apart. My friend says all the pulleys work properly and can see or find nothing wrong...
there was a bypass push button installed on my 2000 dodge carvan before i brought the van--the button goes straight to the starter i dont like it--i believe its because i need a Ignition Switch replacement how hard w...
code p1391 i replaced sensor plugs wires distributor muffler system egr valve im lost researched dodge forum possible flexplate replacement
i ask my friend to do my back brakes he said he knew how i have drum brakes in the back ,disc brakes in the front, with ABS , so he put the brakes on but he keep messing up when it came to bleeding the brakes.long sto...
filled up on sunday with highest grade available at texaco, and at 317 it was empty, recently bought the vehicle and would like to know if this is average for this model
I have a leak but I normal keep the oil filled up I let it run low by mistake and now its knocking...did I ruin the engine?
i have swapped boxes for wires,tested plugs ,fuses,relays,and all are good. i have no power getting to the clutch need help fast getting hot outside.it has been charged .
Battery light still coming on and alternator is not putting out power. checked connections and all good. It seems like there is a fuse blown but i can't find it. Battery was tested and is fine, just needed charged...