» » »

Audi Q&A

Ask Your Question

2001 Audi A6 Quattro Question: Display Issues?

 

Question

ieeaglescoach, 2.7L V6 Turbo, Lake Arrowhead, CA, June 06, 2010, 13:54
 Rookie

We seem to be having continual problems with the information display panel lights, the LED's dont seem to work half the time, very dim or nothing at all especially when its a hot day. Also the ABS light comes on after driving about 20 miles but then goes out. Check engine light comes on and off, but everything has been checked out we replaced the Oxygen Sensor twice. Any help would be appreciated.

1 Answer
Flag This
  • Answer #1

    dandd June 06, 2010, 14:03
    Profile_thumbnail
     Master

    The Instrument Clusters on Audis do go out. So I would start there, I have actually seen, first hand, the cluster set an ABS light, because the Power Train Computer uses the Cluster to talk to the ABS and if it does not see the ABS data, it triggers an ABS light, so start with the Instrument Cluster, which is pretty pricey and needs to be programmed. I have done this job personally at least 6-7 times.
    Then see if you still have an ABS light that comes on, of course after you clear all the codes in all the systems, you need to diagnose the ABS failure, (which is commonly an ABS module) BUT, scan the data stream to be SURE!! If there is still no data output from the ABS module, then it is usually a failed power relay in side the module, meaning you need a new module.
    As for the Oxygen Sensor code, what is the exact code? If it was a P0171 or P0174, this is NOT an Oxygen Sensor issue. Read this article I wrote about lean codes, because many, many techs get confused by this.

    http://repairpal.com/OBD-II-Code-P0171-and-P0174

    Reply
    Flag This