Could it be the fuel pump? on 2000 Nissan Frontier

I thought it was bad gas but after changing fuel filter and putting stuff in fuel it hasn't helped. It runs but likes cuts out and runs real rough. The check engine light IS NOT ON! HELP

by in Gore, OK on November 12, 2010
3 answers 1 comment
ANSWER by on November 12, 2010
Is the CEL (Check Engine Light) works? Is it comes on when you just turn the key to the ON position, without cranking? Sometimes dirty or failing air flow sensor could cause this. It still sends signal to the ECM, so it won't see it as faulty, even if the signals are way off. Zee
ANSWER by on November 12, 2010
ck fuel pressure use heet for water buy at partstore
ANSWER by on May 12, 2011
check the distributor and rotor, the bearings in it usualy go and you will need to repplace the distributor. dont bother with a used on unless ithas less than 60k miles on it. There is a small frat disc with points cut out and the disintigrating bearings block them and causes the engine to run erratically. failure to relace it asap wil cause distributor to freeze up and desyroy the cam sprocket and also may cause additional damage to engine. good luck
2 people like thisFlag inappropiate
COMMENT by on April 17, 2013
my truck starts no problem but stalls out whenever it wants to. i smell gas smells under my truck but smelt that for 3 yrs. replaced spark plugs wires fuel filter air filter and mech told me prob. cat so did that and truck runs ruffs 40 percent of the time. when it starts to stall i have to throw it in neutral and give it gas and seems like its not getting anough gas....all in all nobody nos what to do no check engine lights and moneys tight now after all the parts i put on and no luck.......exhaust pipe is black sooty now not sure whats what please help
Related Items:
I changed the fuel filter and I can hear the fuel pump come on but no fuel could it be the main fuel relay and if so where is it located.
I just drove it home from passing the emission test and the belt broke and truck overheated and coolant all over.
It acts like a bad fuel pump, but I think it's electrical. What could it be?