coolant temp on 2002 Buick Rendezvous

hot coolant temp keeps coming on and temp gauge reads hot?

by in Brockton, MA on April 21, 2010
3 answers 2 comments
ANSWER by on April 21, 2010
You better get this looked at by a shop. Don't drive this if it's overheating, get it towed, you can do more damage if it overheats! Here are some in your area: http://repairpal.com/directory?address=02302&car_brand_names=Buick
COMMENT by on September 06, 2010
I am having the same issue. Additionally, the 2nd engine fan is not coming on but will come on under direct power. Have checked fuses and relays and all seem fine. Have not changed water pump but I really believe mine is the fan just dont know why it wont come on
ANSWER by on September 01, 2010
FIRST I CHANGED OUT THE THERMOSTAT, THE PROBLEM DIDN'T STOP. NEXT I HAD THE HEADS LOOKED AT AND HAD TO HAVE THE VALVE COVER GASKETS REPLACED. PROBLEM STILL NOT SOLVED. NEXT WE ARE GOING TO CHANGE OUT THE WATER PUMP. I WILL LET YOU KNOW IF THIS SOLVES THE PROBLEM OR NOT.
COMMENT by on March 02, 2011
Did changing out the water pump cure your overheating problem?
ANSWER by on March 12, 2011
When this happened to my 2002 . I did everything possible untill It became obvious the the head gasket was the problem. It's fine now, I can't say the same for my knuckels and my back. Parts were about 4 hundred. Including having the heads resurfaced It took a few solid days to get it done. Buick engineers should be assamed of themselves.
Related Items:
why hot coolant temp light keep coming on?
I had the sensor replaced but the gage will not register. My car ran hot due to a clog in the radiator cap.The cap was replaced the radiator hose was replaced and the sensor was replaced but the te...
i have a 2005 buick rendezvous the last couple days it's been acting my temp gets hot and then today the car ran fine thinking it's a thermastat prob. are water pump....HELP Thanks Troy
and engine oil level low but it was oil in there. It would run hot while sitting idle but when it was driven it cooled down.... it got alright for a while then it did it again this time engine shak...