» » »

Ford Q&A

Ask Your Question

1999 Ford Expedition Question: cold air from front heater and antifreeze smell

 

Question

jamesd09, Battle Creek, MI, February 24, 2013, 12:51
 Rookie

I had the manifold and manifold gasket replaced along with the thermostat and since the front only blows cold air when heat is on but the back blows hot now I am smelling antifreeze also since the repair my truck seems to act like its going to die out when I start it and it bogs down when im driving on the highway what could be the issue

2 Answers
Flag This
  • Answer #1

    bmdouble February 24, 2013, 13:39
    Profile_thumbnail
     Master

    When I do an intake manifold job on Expeditions and f-150s I advise my customer that there is a high probability that the intake will have to be replaced as well.The groove that the water jacket gasket sits in often times will chip away,thus leaving the o-ring seal nowhere to sit in,and if it is just put together like that you are guaranteed a leak/s along the intake and then coolant will run into the plug holes causing misfire,rough running,hesitation on accel.Have a look at the front corners of the intake,the low coolant level due to coolant leak is causing your no heat concern as well.

    Flag This
  • Reply

    jamesd09, February 24, 2013, 18:53
     Rookie

    yes I had both manifold and maifold gasket replaced at same time and the coolant is full I just had oil change and they said all fluids were full so not sure why this is still an issue thank you for your help

    Reply
    Flag This
  • Answer #2

    pushrod February 24, 2013, 18:19
    Profile_thumbnail
     Master

    Take it back to the repair shop and let them have a look. I agree with first answer but you stated replaced manifold and gasket.
    Some aftermarket manifolds may require a little more TLC after installiation. Make sure it is FULL of coolant. If rear heat is ok then front should be too. IF it was ok before repair mention that to shop as well.

    Flag This
  • Reply

    jamesd09, February 24, 2013, 18:58
     Rookie

    yes both were replaced along with the thermostat and coolant is full so not sure why its not heating in front or the smell is present I have tried to take it back to the repair shop but seems there and my scedule are contradicting its very frustrating as i have spent alot of money on this truck at the same repair shop pretty sure i wont be going back but at the same time not happy after they repaired it its worse than it was prior to them repairing it fl im in a lose lose situation I did some research online and thought maybe it was the blend door wor whatever its called but not so sure

    Flag This
  • Reply

    pushrod, February 24, 2013, 19:12
    Profile_thumbnail
     Master

    Blend door or more likely the actuator! But should not have changed with repair.
    Good luck with it, that's about all we can offer!

    Reply
    Flag This