Chevrolet Q&A

Ask Your Question

2004 Chevrolet Silverado 1500 Question: CODEPO300 RANDOM CYLINDER MISFIRE

 

Question

GDX, 4.8L V8, La Puente, CA, February 11, 2013, 08:24
 Rookie

HAD LOW COMPRESSION IN CYLINDER SEVEN,HAD VALVES DONE,STILL THE CODE PO300 APPEARS.RINGS OK,NEW PLUGS,WIRES ETC.,NEW INJECTORS,ERASED CODE,CODE RETURNS AFTER @ 3 KEY STARTS.NO OTHER CODES APPEAR. WHAT IS MY NEXT POSSIBLE SOLUTION TO PASS SMOG? THANK YOU

2 Answers
Flag This
  • Answer #1

    February 11, 2013, 10:31
     Master

    did you recheck the compression after you did the work?

    Flag This
  • Reply

    GDX, February 11, 2013, 10:43
     Rookie

    yes compression is normal in all cylinders now. also fuel line pressure, fuel pump ok

    Reply
    Flag This
  • Answer #2

    Greg's Orange Auto (13991 Answers) , Orange, CA - (714) 361-9386
    globalhelper February 11, 2013, 12:55
     Master

    could be anything from primary ign to poss dist is set incorrectly.start by ck'ing dist alignment 1st

    Flag This
  • Reply

    GDX, February 11, 2013, 13:01
     Rookie

    ok thank you.could it possibly be a sensor.i.e cam or crank sensor? reason i ask about the sensors is that a cert. mechanic mentioned them to me, and it is relatively costly to replace them on my budget. thanks again

    Flag This
  • Reply

    globalhelper, February 11, 2013, 13:12
     Master

    yes but dist alignment is very important and will set codes on 3rd cycle

    Flag This
  • Reply

    GDX, February 11, 2013, 13:18
     Rookie

    can you please explain what dist. alignment is,also set codes on 3rd cycle,i would like to relay info, if possible. thank you

    Flag This
  • Reply

    globalhelper, February 11, 2013, 13:28
     Master

    set eng to top dead center and point rotor at #1 cyl on dist cap

    Flag This
  • Reply

    GDX, February 11, 2013, 13:37
     Rookie

    independent coils.no dist cap. 2004 4.8l 1500.

    Reply
    Flag This