Close

2005 Chrysler Town & Country Questions

Get answers to questions about your 2005 Chrysler Town & Country at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
227
questions

Ran fine when parked. Never had any problems before it got very cold. New battery 6 months ago.

The engine in my Van has a harmonic rattle-type sound that pulses, someone told me it sounds like the belt tensioner. I would like to try to replace it myself if possible/

Van is not throwing any codes. Blower for rear of van unit is working fine. Fan will not engage at any speed. Problem just started with no warning. No funny noises, sounds or smells. Everything else electrically is working fine too. What do I look at first to troubleshoot? Local garage telling me ungodly cost and he's guessing on what the problem is.

I was driving, listening to the radio, when I heard and smelled something fry and now the radio is out completely, the power door locks don't work unless the key is at least in the accessory position. The interior lights don't come on when a door is open unless the key is in at least the accessory position.

When I open the tail gate with the remote key, sometimes it will come back down.

i have replaced bcm ,stop light switch ,& turn signal switch still have no stop or turn signals

checked belts alternator. Could it be the idler pulley? Only makes noise when rpm is below 1200 rpm. Any suggetions?

key off stays on till battery dead

This week computer numbers have continually dropped even after being reset and driving normally. Normal hi-way mileage is 28-31mpg; now is only 10-11 mpg, yet fuel consumption on hi-way is still healthy. Vehicle is well serviced by dealer since new May of 2005: just under 99,000 miles. The "dte" figure is now about 700 when normal is max of 500 miles. One mechanic said to disconnect battery for 30 minutes to reset computer -- to no avail. What now - plug in a dealer diagnostic unit?

Heater takes a very long time to heat the temp gauge stays in the middle never over heat. Drive for 20 min heat starts to work somewhat have it all the way up but only comes out Luke warm then it stops blowing warm air and goes back to cold after 5 min or so

at tailgate party about 4 hours long the gate and side doors were open ready to leave the battery was dead no lights or assc. were left on what could prevent the battery drain???? thanks Bill

engine warms up to normal operating temp not overheating. Just blowing cold when stopped then as u start to accelerate warm air blows out