2003 Chrysler Town & Country Questions

Answered 2003 Chrysler Town & Country Questions

Ask a Question
View:RecentAnsweredUnanswered
would not start turns over then there is a clicking noise and will not start
Is there a material that will seal a micro leak in a head?
Are these vehicles proned to Transmission problems particular Input hub replacements after 130K miles
Wife used the van to run to the store. Came home and shut off. Went out to leave and it does nothing. The lights come on etc, also noticed the steering wheel is not locked. We are desperate! Just lost work so any assi...
Only does it when its above 80 degrees outside, on hot restarts the PRND3L is fully lit and it is in limp mode, after a 30 min cooldown it will be fine just the check eng light is on and throws a 1698 code. Got a TCM ...
My ABS light came on and my mechanic told me I needed a new ABS pump. When I got my van back, half the dash lights are not working (including my E-brake light and ABS light area as well as the left side fuel gauge and...
how do you change the lower control arm bushings in a chrysler van
EVERYTIME I TURN ON THE AIR IT LEAKS IN TO THE FLOOR ON PASSAGER SIDE NOW IT IS STARTING TO GROW WHITE MOLD WHAT CAN I DO
The air circulation fan is on high all the time even though the power to the heat/ac system is off.
Driver's power window stuck in up position. We have removed door panel to check wiring, motor etc. Is there any way to tell if it is the switch or the motor? The wiring seems ok.
i moved the sensor(?) that made the check motor\oil lights come back on with all others when first starting up like normal. then it started. later on i tried and it wouldn't turn over. has not sense.
question about a 2003 town and country dvd player on roof. MINE HAS A SUNROOF 1 DVD PLAYER how can i find out what kind of cordless headphones i need to buy to work in my van?
The sliding doors wont work at the door button but will work with key and overhead buttons.
What do the numbers 0420, P16847, P1282 mean?
I have no power steering what so ever and the belt is fine. What could be the problem? Electrical, broken pump but not the pulley, rack and pinion,?