81
questions

checked BCM for codes= none, A/C has no charge,why do all switches flash when vehicle is started, wipers work, even disconnected battery to see if it would reset no luck. any advice? thanks

the van has 188,000 miles. transmission started slipping when i was driving on hwy. i pulled over, checked fluid but it was fine, not burnt in color and no leakage, juast a high pitch whistle sound. started driving again and it started off fine but slipped out of second so i slowed down until it caught again and i just kept driving for another 100 miles at 45 - 55 mph at approx. 4500 rpm

My passenger window will roll down with both driverside&pass side window controls but wont roll back up on 97 Chry Town&Country,Also my pass side rear window wont open or close

Do I need a control module or is it the electrical hook-up?

i just got this van.what could i do to find out what is wrong.

The batt.is fine( new) starter fine Starts with the remote. Keys are fine have 3 different ones all have worked fine before.The van is lock happy, you don't dare get out without the key in your hand somtimes it locks & somtimes it don't I don't think this has anything to do with the starting problem Please Advise !!

360 motorhome(beaver)

I want to replace the relays on my 1997 Town and Country and am not sure about the amperage of those relays in the distribution center.

Need to know where the neutral safety switch is located at on my vehicle

The charge light comes on normally after travelling for more than twenty miles. The check engine light flash pattern was 12 46 55. After restarting the car, the light would normally stay off for rest of the day. Voltage of battery was 12.4 when car not running and 14.0 when car is running.

drove the van about 23 miles when someone flaged me over and told me my back-up lights were on while driving.We have taken them out. Why and how do I repair them?

when I'am driving my minivans shot off and it happen all the time

My van has been shutting down on me as I drive, if I am going down the interstate,when it cuts off, I am able to restart it right away. However, sometimes It will let me seat for 20 minutes before it starts back up again. So far, I have replaced the fuel pump, the main swith that generates electricity, the gas filter and some other sensor. Will you please help me figure out this problem

i need a diagram of driveshaft unit, need to no how to get back housing unit on

i accidently broke the bulb on the fog/running light and i was wondering can i get a replacement bulb or do i need to replace the whole unit??
jaybriski75@yahoo.com thank you