2000 Chevrolet Tahoe Questions

Answered 2000 Chevrolet Tahoe Questions

Ask a Question
View:RecentAnsweredUnanswered
heater and defroster blow cold and changed thermostat and antifreeze levels are good?
Antifreeze level is good and changed thermostat.
After inspecting the system and tightening the gas cap I reset the alarm via OBDII scanner. After a few days without any variable changes the alarm returns. My thought is that if there is an actual fault, then the al...
Ive replaced the actuator under the dash and both in cab air filters what else could be wrong
When I put the seat down, I do it gently..it is an old truck. When I tried to put it back in upright position, the 60 side will not lock into place. I have made sure the headrest is up and pulled the strap to make s...
What would cause the front to only blow cold and the back blows strong for both hot or cold. I was told maybe it might has something to do with a level not changing or moving from cold to hot. In the front heater con...
what would cause all four brakes to drag after replacing all caliper 2 rotors on front wheel speed sensors serviced by gm due to recall this immedietly made problem worse.mechanic and i decided master cylinder would b...
I need to replace it. I do not mean the main air filter in the engine compartment.
It will start right up and run for a while then just quickly die wait a minute then it will start right up and run for a while then die. It won't run any longer than a minute or two. I was thinking control module, fu...
The horn and the horn sound when you use remote locking isn't working.
I was driving down the road and engine just stopped. First time this has happened. Will not restart and all lights, radio, locks work. Not the battery. 2000 Chevy Tahoe and 150,000 miles.
sometimes the front gets a little warm then stops and goes back to coolthe backs stays warm for the most part but recently it also goes cool on occasions
How thw Heck can i remove the long panel to straighten out the belt ?? Thanks Mike
We have a 2000 Chevy Tahoe with about 156,000 miles. Our service engine soon light has come on and when the code was pulled it had said it was the evaporated emissions system. I was told it could either be the gas cap...