1991 Chevrolet S10 Questions

All 1991 Chevrolet S10 Questions

Ask a Question
checked fuel pump, fues, and relay.
thermostat has been changed,hoses are all hot to touch,hoses out of heater core are both hot,cable style control inside of dash seems to be working( i hear flaps moving around)..what could it still be? its not like a ...
Heater coil has been replaced as well as heater hoses and radiator fan runs but blows cold air
not sure if the above is the solution. My check gauges light comes out at low idling and oil pressure stays in red zone but goes up at i accelarate. oil level is normal.
it has been doing it more often it idles really rough step on gas a little then it will idele better runs really good just does it after it sits awhile or over night
I was told by a friend that this requires dropping the entire steering column.
I would like to check it myself at home with out taking it to shop.
173,000 miles on it, fuel filter an tuned up at 140,000, stumbles bad when u try to accelerate, no gas smell, just started all of a sudden, put regane fuel system cleaner in it an didnt help, feels like its in fuel sy...
I have released the screws, but cannot get the switch to come out. I think I need to replace the vacuum hose(s) attached to the back. Where can I get those hoses?
Have a '91 4.3 L that backfires after it is started, have installed new plugs, coil, rotor/cap, wires, this is a reman engine with 20,000 miles on it, lifters are ticking real bad on rt. front, I think from the backfi...
It all started when my starter went out. After replacing and putting proper shims, i shut down and restarted the truck about 6 times and then when i was just about to shut it off and take it off the jack, it just died...
fuel pump replaced and still unable to operate truck
Recent new fuel pump. Told tank more than 3/4 full. Gas gauge does not work. Engine died. No gas? Put in 1 gallon. Started after half dozen tries. Went across street and tried to fill up. Could only put in 3.21 gallon...
I HAVE HAD A VACCUM LINE COME APART FROM THE TRANSMISSION KEEPING IT FROM GOING INTO 4WD. WHERE DO THESE LINES GO? WHERE CAN I FIND A DIAGRAM OF THIS? THANKS RICK