78
questions

just this time new battery

air conditioning, fuel gauge, radio cruise control, temp gauge wont work what do i do

the car keeps trying to turn on without the key in the switch so I have to unplug out the plugs I want to know why it is doing that

it act like it was gone to start but didn't. replace fuel pump relay switch and nothing happen try to reset theft system by letting key on for 20 min and still nothing know what to doneed help

I guess a specific problem will be deleted by disconnecting for a certain duration, then connecting again.

I've heard about for reinitialising data for the bad use of "At a distance starting key system"

After a while good working... these failed : no more flashing neither left or right; hazards go on good working.
The right arm for cleaning window just operate on two highest speed, none action when pushing for liquid on glasses.
Should it be a good idea to disconnect battery for 10 minutes, what about this way of doing...for what problems ?

come on it dont start but radio and everything does come on .. once the gas gauge works and stuff it will start any ideas ?

when the blower works it dont work all the time either what is the easiest way to check whats wrong with it

Car was purchased new back in '02, no real issues until last year when this started to happen, has 67,310 original miles on it. Car hesitates, no acceleration past 35 mph, problem is getting worse. Actron super AutoScanner gives no code/MIL set. No check engine light alert. Car does not shake or make any noises, seems fine except for the acceleration issue. Car has acted odd a few times upon starting, turned it off, restarted and car was fine. Car died once at a stop light but restarted right away. Problem began months ago with just struggling to get up hills, but now it's bogging down all the time. Here is the list of parts I've replaced to try to fix the problem with no effect.

Spark plugs, spark plug wires, PVC valve, fuel filter, both O2 sensors (upstream & down), coolant temp sensor, EGR valve, upper & lower manifold gaskets (lower did have leak & cleaned inside and out, lower injector O-rings, MAP sensor, throttle body gasket (cleaned inside & out), switched out with good MAF & IAT sensors (no improvement).
Checked fuel pressure - ok
Checked Coils - ok
Checked fuel regulator - ok
All this has had NO effect on the lack of accleration.

Any ideas? Any suggestions?

I can add water over night and it will still be full in the morning. But I can only drive about a mile to a mile in a half before the water evaporates. Water has to be added after a mile of driving the water reserve thing will be empty. the overheating indicator moves to over the half way point rather quickly. Therefore I can't drive for fear of overheating and causing more damage. I have not noticed any leaking of the water or other fluids for that matter.

I'm DYI-ing a coolant flush, just need some help per this specific car, I get how to do it, just need help looking for the right things, ie the lower drain.

trouble p0111 iat replaced Iat airfilter replaced tran,shift hard

I was driving came to a light & engine shut off tried to restart & the engine wouldn't fully turn over. Battery started to go low tired a jump still couldn't get engine to turn over. Was told it sounds like alternator went out. Any suggestions?

Car overheats frequently.

My car started jerking while excelerating and the check engine light came on.