1999 Chevrolet Malibu Questions

Answered 1999 Chevrolet Malibu Questions

Ask a Question
View:RecentAnsweredUnanswered
The fuel pump is running even though it makes a humming noise on top of the buzz noise it always made. For the most part it would start right up besides the theft crap we all go through with these cars from time to ti...
even when the tank is empty and if i force it in it drains out. The gas gage just started to stop working and then working.
Hi, in my car(1999 chevy malibu,4 cylinder) check engine light is on, and it is shaking when car is started & drive with lower than 20Mph. when i shown to some of known mechanics they said problem in coil set & i must...
I just had a newer engine put in this car. I have too much money in it to junk it. It has a new tranny, all brakes, rear axle, windshield, springs, hubs, etc.... I just spent $1500 on the engine swap. Same guy is...
I was driving along and went to slow down i hit the brakes and it barely slowed down like the brake booster was shot. The brake booster holds vacume most of the time if booster goes bad it dont hold vacume and now the...
do you think it could just be the rear head gasket blown,no water in oil or no steaming,it runs good.it did overheat.think maybe the head gasket is blown.it is leaking right between head and block,pretty heavy while r...
Jumped time need to reset it chain does not look broke nor does the cams look like they have lost any teeth..
Balancer needs to be change and I don't know how. Thank you.
Can you tell me if its the pressure switch or something else
2 times in the month ive noticed it idleing high but if i shut car off and restart it seems to be ok this time the check engine light came on and will not shut off?
It will start and stall after few mins idling. Sounds like a tapping the higher it idles the faster it taps and I saw puff white smoke come from the valve cover as it stalled. Was thinking bad valve cover gasket and o...
some one tore up the switch we changed it and now we can't start it.It turns over but no results in starting it.
I had a diagnostic test done and the guy said that it was the theft deterrant system fuel cutoff what can I do???
I shut key off it returns and restart it returns to normal sometime it last and sometime drop back to empty
When i took the bolt out to replace the belt tensioner i got screw filler shavings or what looks like a boltscrew holder inside.. What are the called and how do i ask for them???