» » »

Dodge Q&A

Ask Your Question

2008 Dodge Magnum Question: check engine light is on & now car won't start. cranks but wont turn over?

 

Question

judsine, 5.7L V8 HEMI, Woodbury, NJ, October 17, 2012, 06:09
 Rookie

the light came on yesterday with a second light, a lightening bolt. the lightening bolt then went out but the check engine light stayed on. Today the car won't start, it cranks but won't turn over.

2 Answers
Flag This
  • Answer #1

    Greg's Orange Auto (13671 Answers) , Orange, CA - (714) 361-9386
    globalhelper October 17, 2012, 06:18
     Master

    you may have a throttle issue.have codes scanned at auto zone for free and post so we can adv. if car will not start seek help from your mech

    Flag This
  • Reply

    judsine, October 17, 2012, 06:48
     Rookie

    thank you so much, not having much luck getting it started so will get it towed to my mech.

    Reply
    Flag This
  • Answer #2

    Lungedoe13 November 01, 2012, 21:08
     Rookie

    Ok.. I just purchased a 06 Dodge Magnum SXT from my brother w/ only 87,000 miles on it. But the problem is that the car barely turns over, and when it does it only runs for a few seconds and then stalls. The check engine light as well as the lightning bolt between ) ( is flashing. The battery is also dying on it so I have to get a jump every time I have something done to the car. 1st took it to my a recommended mechanic and he told me that the "computer" PCM needed to be reset, or "flashed' so I got the car towed to the dealer to have the work done. The dealer supposedly flashed the PCM but the same problems still persist, so I had them do a diagnostic. Afterwards, they told me that I needed a new PCM, Tipm, & a Throttle Body Assembly. Parts along with labor totaled $2,200 dollars so I ended up just paying for the Dianostic/PCM flash and got the car towed back to my house. I then got my mechanic to look @ the car and he went to the Tipm and noticed that one of the connectors for the Front Control Module was damaged so he disconnected it and the car started right up, but it stalled within 2-3 seconds afterwards. He told me that I needed a new FCM but I'm not sure if he's right so I was looking for a 2nd opinion to prevent me from buying something that I don't actual don't need. I've also been told that it could be a problem with the security on my car and that it may need to be reset due to my battery dying. So, does anybody have any idea of what the problem could be with my car?

    Reply
    Flag This