check charging system on 2005 Lincoln LS

while driving on-board message center indicates check charging system and the battery indicator light comes on, the spedometor goes to 0 however RPM's remain normal the radio cuts off, my sterring becomes tight and the car shuts off and will not start, no lights working in dash and hazard lights go on and off outside the car.I get a jump and the car starts but shuts right back off immediately. New battery has been replaced less than 90 days any suggestions/ideas?

by in Lockport, NY on March 20, 2011
1 answer
ANSWER by on March 20, 2011
Charge the battery to a full charge. then check to be sure alternator belt is tight and battery cables are clean and tight. Have the alternator output checked it should be about 14.5 volts. If you are not getting 12 volts to the PCM you won't get the other reference volts to the sensors needed to keep the engine running.
2 people like thisFlag inappropiateReply
Related Items:
my check charging system came on and the battery light. replaced battery and lights still on what else should i check?
i have replaced the alternatoe and battery and the check charge system light wont go off
Hi all, having issues with the ride. My car will be driving fine, then these episodes will occur. First the temp gauge starts dropping completely to cold,a fan comes on, the car loses power, surge...
While going down the road the a/c cools fine. If you stop at a red light, it keeps blowing, but not cool air. Local mechanic checked and said the high pressure side was reading 140 -should be 225...
No diagnostic codes (DATC); repaced DCCV today, no difference. Followed thread to get to the point I ma now, could use some help. Thx, WJL