change engine oil message on 2002 Chevrolet Suburban 1500

120 miles ago, I had my oil changed and now each time I start the engine I get a 8-10 second change engine oil message. The truck runs great, no other messages. 142000 milses! Any answers? Thank you

by in Ellenton, FL on May 02, 2009
5 answers
ANSWER by on May 03, 2009
The shop did not reset the oil change system. Take it back and ask them to do so, for no charge of course, as it should have been done with the oil cahnge.
1 person likes thisFlag inappropiateReply
ANSWER by on December 11, 2009
try putting the ignition key to on (but the vihecle not running)so that the lights on your dash information go on and then pump the acceralator 3 times, wait 3 seconds then turn the truck on and if it's still on try one more time. When I change my oil that is how I clear the code.
1 person likes thisFlag inappropiateReply
ANSWER by on March 23, 2010
put the key in the on position pump the gas five times then start the truck this should take care of that issue
2 people like thisFlag inappropiateReply
ANSWER by on December 28, 2010
While the auto is running (in park) pump the brakes 3 times and it will go off.
ANSWER by on March 17, 2013
they didn't reset the oil mileage on the onboard computer take it back and have them reset it or do it your self look in your manual to see how
Related Items:
I had just noticed that the "check oil level" message appeared on the DIC. This has never appeared before. All fluid maintenance is up to date. Is the engine burning oil or is it that the computer ...