2010 Chevrolet Silverado 1500 Repair and Maintenance

A guide to problems, costs, maintenance and repair for your 2010 Chevrolet Silverado 1500

Will turn key and it is like no power from battery to starter, but have lights, radio, etc. Turn key again or sometimes multiple times, to no avail. Then, turn it one more time and it starts. Then the next 15 starts, no problem. Sometimes hot engine, sometimes cold.

UPDATE: 2-6-14; I sold the truck to my father. He changed the starter. No problems since March 2013.

The speedometer or other instrument panel gauge may begin to work erratically at times. Our technicians tell us that the instrument cluster must be sent to a repair facility to correct this fault. The warranty has been extended on some of these units to 7 years or 70,000 miles.

One or more heater & AC (HVAC) air delivery and/or temperature mode door actuator may fail. This can result in incorrect air delivery or temperature. If this occurs, fault code(s) stored in the HVAC control module should be available to assist with diagnoses.

See More Problems 10

I don't know what the problem would be but I'm still able to switch from 2 hi to 4 hi. The light indicates I have put it into 4x4 and it doesn't fishtail in the snow like 2 hi does, so I know it's working. But strange that traction control did not want to kick in when I fishtailed...

I have a 2010 Chevy Pick up, My alternator is continually putting out 15.5V Tester says battery needs charging, but has 80% charge.
I put battery on charger and it charged competly in about 30 minutes. is the problem in the alternator, Battery, or is the computer telling it to charge?

See More Questions 20

New crew cab truck (only 5k), so far, great. Just drove 2,000 miles in 3 days. Everything worked just fine. Comfy leather seating and 5.3l made the miles just roll along. Quiet and strong. Got even 19 mpg on trip, according to DIC.

I am having a problem with the oil pressure sensor but found out the engine is bad and needed to be replaced the truck is in very good shape no other problems this happen at 97,000 miles and 5 days after the 5 year mark so no coverage. Any others out there having the same problem? The dealer says something in side the motor not sure what.

See More Reviews 2