1991 Chevrolet S10 Blazer Repair and Maintenance

A guide to problems, costs, maintenance and repair for your 1991 Chevrolet S10 Blazer

1991 Chevrolet S10 Blazer Problems

The heater core under the right side of the dashboard may leak engine coolant which can puddle on the passenger front floor. The loss of coolant may cause an engine overheating condition. Our technicians tell us that removal of the dash board is necessary to replace the heater on these vehicles.

The transmission output shaft seal may leak transmission fluid. On 2WD models, this leak can cause the transmission mount to become oil soaked, which will require replacement of the mount along with the leak repair. On 4WD models, if this seal leaks, the fluid will leak into the transfer case, causing it to become overfull.

A door window may move slowly or stop in mid travel due to a failing power window motor. The affected window may start working again after the motor cools off. Replacing the faulty window motor will commonly correct this concern.

See more problems 12

1991 Chevrolet S10 Blazer Questions

Last winter parked my vehicle first outside, then inside, vehicle sat for a while, wouldn't start. put treatment in gas, still wouldn't fire. Bought some parts to change out, debating on junking the car out. Bought a coil, rotor, module and cap. Started out by changing the coil as the spa...

I have replaced most vacuum lines but the line from the carb to the vapor canister when I take it off it does not change anything no difference?

i need a picture or manual? please

See more questions 42

1991 Chevrolet S10 Blazer Reviews

overheats,have to kick the dash to see the fuel gauge,rpm gauge does not work,windows take forver to roll up,stalls out at stop signs/red light or if you take the turn too fast,can't drive it for more than three hours after that it shuts off,rear end sags,need realignment,new upper and lower arm bushing,extremely needs a complete rewirng,interior lights does not work,shut off when it is hot,or ...

1991 s-10 blazer fuel gauge says full all the time. sending unit is a year old.was working but not now.thought it was the ground. ran ground to battery and still didn't work.still says full

See more reviews 2