Car wont start on 2000 Mazda Protege

Theres fuel, spark compression and the timing Belt is good. The car cranks but wont start replaced the mass air flow sensor so thats out. After the car cranks it smells a lot like gas like if theres to much fuel. It sounds like it wants to start but nothing. Cant get the codes because my dad decided to take the battery out. Plz help

by in Granada Hills, CA on January 14, 2014
2 answers 2 comments
ANSWER by on January 14, 2014
Have you pulled the plugs to see how fouled they are?
COMMENT by on January 15, 2014
Took them out after trying to turn it on for a wile there dry a lil dark but dry
ANSWER by on January 15, 2014
do you have any eng codes?
COMMENT by on January 15, 2014
No codes my dad took the battery. My check engine light came on last month n it gave me the code for cilinder1 missfire. No other codes
Related Items:
after car sits for a few hours it takes a long time to start,i smell fuel,and it sounds like it wants to start, but wont,only after 15minutes or so of cranking the car finaly starts, after that it ...
put a new starter in and it still wont start doing the same exact thing as before the new starter. all lights come on, when you turn the key it clicks one time but wont turn over. jumping it doesnt...
cranks but no spark,and fuel pump wont kick on.ive replaced the distributor,with another used on(car was running)....the crank positioning sensor reads .557ohms what could be the problem?
has great spark, no codes . still flooding. acted like it was going to start when holding accelerator to the floor, but still wont run.

Related Content