» » »

Mercedes-Benz Q&A

Ask Your Question

1999 Mercedes-Benz E430 Question: Car vibrates

 

Question

Reyna1990, Mount Laurel, NJ, December 11, 2009, 16:54
 Rookie

My car vibrates when it comes to a complete stop. It otherwise drives very smoothly; however whenever I stop at a light/stop sign it shakes and it makes a rumbling sound. I just had the spark plugs, the air filter and the fuel filter replaced and that didn't fix the problem as the dealer had suggested its actually worse. Any suggestions on what's going with my car? Thanks

4 Answers
Flag This
  • Answer #1

    matte December 11, 2009, 17:04
    Profile_thumbnail
     Master

    A rough idle can be caused by a number of things. The items your dealer replaced can definitely be at fault, but so can a number of other items. It's a little troubling that they didn't do a thorough diagnosis to pinpoint what is at fault.

    You can try cleaning the fuel system by using a bottle of Chevron Techron Concentrate Plus--sometimes that helps.

    Otherwise, you could negotiate with the dealer, as they didn't fix the problem with the work you had performed.

    Flag This
  • Reply

    Visitor, August 11, 2010, 01:29

    Based on my experience ... check the motor mounts. My car has a bit of idle roughness in neutral only. The only fix has been new motor mounts (twice). I ignore it now because of the age of the vehicle, it is not pronounced so I will wait until it becomes more of a problem. Other than that ... zero problems with the car.

    Reply
    Flag This
  • Answer #2

    Visitor, March 28, 2010, 11:16

    maybe change the coil packs

    Reply
    Flag This
  • Medium-star Best Answer
    Visitor, April 04, 2010, 14:24

    its either the coils or motor mounts. if your car just shakes at a light and not why your driving than its the mounts. if it sputters while your driving than its the coils. i had both problems on my 99 e430. if engine light is on than its misfiring cause of the coils.

    Reply
    Flag This
  • Answer #4

    Visitor, January 30, 2011, 08:20

    Sounds like motor mount. If the engine runs rough in Park or Neutral, it is most likely you have engine problem. If the engine runs rough in gear, most likely it is motor mount. In Neutral or Park, engine is disengaged from the drive train there is no resistance. When in gear, there is resistance. The engine is turning one way and the the rest of the car is trying to turn the other way, this causes the engine seem to run rough.

    Reply
    Flag This