Car stops shifting and fails when hot on 2003 Toyota MR2 Spyder

Hello, I have been having trouble with my car for about a year now. Basically when it gets hot (around 3 miles) it fails while shifting. If you give it a few minutes it will start up again, but keeps repeating. I have bought a GSA, HPU, and both Engine and Trans computer. The relearn procedure on the Trans computer will not even begin to do the first step. The codes we keep getting are 1646 and 860. With one of the computer combos (tried all four computers in combinations with each other) we got code 919. My husband is a mechanic and has the repair manual and wiring diagram. don't want to throw more EXPENSIVE parts at it if not sure it will fix. The local dealership wants nothing to do with it. I read alot of people having the same problem, but never see any resolution. Any help would be greatly appreciated. Maybe transmission itself is bad? thanks

by in Saint Petersburg, FL on September 09, 2010
2 answers 1 comment
ANSWER by on September 09, 2010
try this chemical that helped my old merceds that used to do the same thing. "guaranteed emission pass" I think I paid like 14 bucks. Read the instruction on the box carefully for a better performance. good luck!!
COMMENT by on September 09, 2010
Thanks for your rapid response, I am willing to try anything at this point :)
ANSWER by on October 22, 2010
IM A TOYOTA MASTER TECH. YOUR PROBLEM IS WITH THE TRANS ECU CONNECTOR. I HAD THE SAME PROBLEM WITH ONE, SAME CODES AND ALL. IT TOOK A LITTLE WHILE, BUT GOT IT.