car starts cold then runs rough and stalls won't start again on 1993 Oldsmobile Cutlass Ciera

This has progressed. Ran it on my property for about a yr at below 15 mph, then it fired up one day and when it warmed up it started running badly then stalled. It progressively got worse until now it won't start at all. When it was starting it cranked up immediately after turning the key but as it warmed, it stalled

by in Oxford, MI on October 29, 2009
2 answers 3 comments
ANSWER by on October 29, 2009
Is the check engine light flashing if it is count the flashest and tell me what numbers you get so i can look up the codes for you, i would check the MAF sensor
COMMENT by on October 30, 2009
to: sinautoscan: I checked the code on the check engine light: It flashes once, pauses and then flashes twice, so is that a 12 or a 1, 2?
COMMENT by on October 30, 2009
also, I pulled the MAF sensor, cleaned it with carb cleaner and replaced it. It didn't look damaged or badly soiled. Air cleaner is clean; however, I spotted a small vacuum hose right next to the MAF sensor that felt like it might be cracked, so I temporarily wrapped electrical tape around it. It goes from a housing right next to the MAF down to the front valve cover (aluminum tube to hose to aluminum tube). Maybe when it heats up the tube weakens and allows more air flow. I'm charging the battery right now, so, can't try starting it. What do you think now?
COMMENT by on October 30, 2009
OK, so the battery is fully charged, engine cranks like crazy but not even a hint of starting up now! ????????
ANSWER by on February 26, 2010
is there a gas smell in engine compartment? if so its possible that your fuel pressure regulator is bad.

Related Content