car starts and wont stay running on 1997 Oldsmobile Achieva

We have an achevia 97'. The only key we got with it was the one someone had cut from the original. We just got the car. We got the car home. I parked it and went in the house for a little bit then went to leave and the car would start but wont stay running and the security light is reading. What do I do. I tried the reset and it killed my battery.

by in Ford City, PA on February 18, 2014
2 answers 5 comments
ANSWER by on February 18, 2014
Possible passlock issue; Is there a chip in the key.
COMMENT by on February 18, 2014
it has the black top on the key that is what I was told is where the chip is suppose to be. what do I need to do?
COMMENT by on February 18, 2014
First try to turn the key to run, do not start, and let it sit for 10 minutes, or until the security light goes off, then try to start it. Might have to do this 3 times. Let me know before we go further.
COMMENT by on February 18, 2014
did not work. got a new key and it did not work with new key either
COMMENT by on February 18, 2014
Ok I want you to understand what is going on so go to YouTube and search videos, put in passlock and there is a lot of information on all the passlock systems. That should give you the information as to what is going on and what needs to be done next.
COMMENT by on February 18, 2014
ok thank you
ANSWER by on July 25, 2014
I have a 97 and the answere is that olds locks up the engine after several miss starts. put the key in then turn it to the on position and bump the key forward as if to start it but then release the key and leave it in position for 10 minutes. Now turn off the ignition for 10 seconds then turn it towards on but do not try to start it for 10 more minutes. Now again turn off the ignition for 10 seconds then turn it towards on but do not try to start it for 10 more minutes. On the third time you turn it off for 10 seconds and turn the switch to on the engine will start. It works my 1997 does it all the time. Larry
Related Items:
Hi, My 95 achieva 3.1 v6 wont turn over. Only makes a clicking noise. Well before this yesterday to be exact. I bought new vaccum lines as mine where cracked. The car didnt want to stay running so ...